Troubleshooting | TouchMix 8/16 will not turn on

Learn how to troubleshoot issues with your TouchMix 8/16 mixer not powering on.

Updated at February 21st, 2024

Affected Products

Hardware Model/Series TouchMix 8/16
Software  

Problem

TouchMix 8/16 will not turn on and may experience the following symptoms:

  • TouchMix LCD and LEDs do not illuminate when power is applied to the external power supply.
  • The led on the power supply does not turn on when plugged in.
  • TouchMix randomly powers on and off when cable/mixer is slightly moved.
  • No activity on the mixer at all. The LCD display, blue LED ring around the rotary encoder, and buttons do not illuminate. The mixer appears as if it’s not receiving any power.
  • The mixer hangs during the initial boot. The blue LED ring around the master encoder illuminates but nothing else is active on the mixer. There will be no activity on the LCD screen.
  • The mixer hangs during the initial boot but may get a little further in the boot sequence then the previous variation above. The difference is that there is activity on the LEDs and LCD. The mixer may hang on the “Loading” screen, “Initializing” screen, or the white splash screen between the “Loading” and “Initializing” prompts.

Causes

Issues with the TouchMix-8 and TouchMix-16 not powering on can be categorized in two ways depending on how the symptoms of the fault are seen on the mixer.

  1.  An issue with AC power feeding the power supply or the power supply itself.
  2.  An issue with the internal microSD card.

Solution | Workaround

Issue with AC Power Service or the  Power Supply

Verification

  • Verify that the AC service is supplying proper and steady voltage for your region.
  • Verify that the GREEN LED illuminates without plugging the 6-pin DC connector in to the back of the mixer while applying AC voltage to the power supply.
 
 

Resolution

  • If the AC service is stable and there is a green LED, the fault may be related to something internal to the mixer.  The mixer should be evaluated by a QSC service partner. https://www.qsc.com/support/product-repair/
  • If the GREEN LED does NOT illuminate when power is applied and it is not plugged in to the mixer, the power supply will need to be replaced. Part Number: PW-000108-02
 
 
 
 

Issue with the Internal microSD card

Verification

There is no additional troubleshooting required if the mixer is exhibiting the symptoms described above.

 
 

Resolution

The mixer is experiencing a corruption or fault on the microSD card which contains the TouchMix OS.  The microSD card will need to be replaced by QSC service partner.