Troubleshooting | L Class showing a black screen on the Rear User Interface (RUI)

Learn the steps to troubleshoot an L Class display that is not showing an image on its Rear User Interface (RUI).

Updated at September 8th, 2023

Affected Products

Hardware Model/Series L Class - LA108, LA112 Active Line Array Loudspeakers
Software Firmware 1.1.0033

Problem

In very rare circumstances, when powering up the LA108 or LA112 loudspeakers, the unit will not boot properly and will display a black screen on the RUI. The loudspeaker will show a blue LED power indicator on the rear, however the unit will not pass audio and will not be recognized via the SysNav™ App.


Causes

This is a known issue in L Class firmware 1.1.0033.


Solution | Workaround

This issue can be remedied by utilizing a recovery mode and by uploading the latest firmware to the unit via the SysNav App.

Preparation

  1. Visit the SysNav App download page to ensure that you are utilizing the very latest version of the software. 

    Note

    The SysNav version you are running will be displayed as you open the app, and can also be found by navigating to the app Home Page. 

     
  2. When utilizing networking equipment during the firmware update (such as a router or a switch), ensure that the equipment has had time to complete its boot sequence before attempting to connect any devices. On routers, make sure to use the Local Area Network (LAN) ports. 

    Warning

    Do not use the Wide Area Network (WAN) ports.

     
  3. If an iPad is used for the firmware update, ensure the following:
    1. If utilizing Wi-Fi for the loudspeakers firmware update (not recommended), make sure all ‘Auto-Join Networks’ are disabled (other than the network that will be used to update the firmware). 
    2. Do not navigate away from the SysNav App or use the iPad for any other task during the loudspeaker’s firmware update process. 
    3. Do not let the iPad go to sleep during the update process. This setting can be modified by navigating to Settings > Display & Brightness > Auto-Lock > Never.
 
 

Procedure

  1. Place the faulty loudspeaker next to the updating device and remove the power cable from the loudspeaker to ensure that the power is off.
  2. Run an ethernet cable from the designated updating device (Windows PC or iPad) to one of the open Ethernet ports on the loudspeaker. 

    Note

    If you are utilizing Wi-Fi for the update (not recommended), the Ethernet cable will need to run from a LAN port on the wireless router to one of the open Ethernet ports on the loudspeaker; the iPad can then be connected to the wireless router via Wi-Fi to proceed with the loudspeaker firmware update.

     
  3. Once the ethernet cable has been connected, use your left hand to hold down both the Menu and ID buttons on the rear of the loudspeaker, and use your right hand to reattach the power cable. If this procedure is correctly completed, a Red Bar will appear on the loudspeaker RUI screen stating “Upload Valid Firmware Image”. You can stop holding down both buttons.
  4. Next, open the SysNav App on the designated updating device. Navigate to the menu in the top left corner of SysNav and select the ‘Updates’ tab. 
  5. In the ‘Updates’ Tab, confirm that the loudspeaker has been recognized by SysNav. Check the box next to this loudspeaker to select it as a candidate for firmware update.  
  6. When ready, press the ‘Update Firmware’ button at the top of the page. SysNav will show an update progress bar for the loudspeaker that is being updated. 
  7. When the firmware has finished uploading onto the loudspeaker, the RUI will display a completely black screen for approximately 90 seconds, and SysNav will list the loudspeaker as ‘Offline’. This is normal. 

    Warning

    Do not interrupt power during this time.

     
  8. After the firmware has completed installation, the loudspeaker will reboot on its own.
  9. Next, perform a Factory Reset by holding down the Menu and ID buttons together for a few seconds. The factory reset process takes about one minute and will show a progress bar on the rear user interface.

    Warning

    Do not interrupt power during this time.

     
  10. Once the loudspeaker has rebooted, after the factory reset, it is ready to be used.